Wait times are intermittently spiking to 100 or more seconds on all clouds. These spikes only last about three minutes and occur about once every two hours. We are investigating the cause.
2019-May-2 Minor Service Incident
Incident Report for Sauce Labs US West Data Center
Postmortem

Dates:

May 2nd, 2019 12:14 PM - May 2nd, 2019 12:26 PM CEST

What happened:

The real device selection page on app.saucelabs.com was unresponsive which made RDC Live Testing inaccessible from our UI. The Live Testing service itself was unaffected and continued to operate normally.

Why it happened:

An API endpoint was inadvertently removed from our service.

How we fixed it:

The API endpoint was added back to our service.

What we are doing to prevent it from happening again:

We are adding internal tests in our staging environment to be sure the device selection page functions in our UI before any new deploy to our production environment.

Posted 4 months ago. May 20, 2019 - 02:39 PDT

Resolved
This incident has been resolved.
Posted 5 months ago. May 02, 2019 - 03:26 PDT
Identified
The UI for manual RDC tests at https://app.saucelabs.com is currently unavailable. Manual RDC live testing is available at https://app.testobject.com/. We have identified the problem and are currently working on a fix.
Posted 5 months ago. May 02, 2019 - 03:12 PDT
This incident affected: Manual Testing (Manual RDC Testing).