A SSL certificate in the chain of the certificate used for TLS 1.2 on https://app.testobject.com has expired.
Any client (web browser, REST API client) using TLS 1.2 and making requests to https://app.testobject.com may see “certificate has expired” errors. Any client using TLS 1.3 is unaffected. We are working to rectify this issue.
2020-July-21 Service Incident
Incident Report for Sauce Labs US West Data Center
Postmortem

Dates:

Wednesday, July 21, 5:08 - 7:40 AM PDT

What happened:

The SSL certificates required for serving test assets and a portion of the user interface had expired, making the dashboards in all data centers inaccessible.

Why it happened:

The renewed SSL certificates were not set properly.

How we fixed it:

We immediately re-configured the renewed certificates and re-loaded the affected services.

What we are doing to prevent it from happening again:

We have increased the automation of our SSL certificate management and improved our monitoring.

Posted Aug 03, 2020 - 09:34 PDT

Resolved
This incident has been resolved.
Posted Jul 21, 2020 - 07:40 PDT
Identified
The issue is largely resolved, but test detail pages are currently unable to display assets (logs, screenshots, video). We continue to investigate.
Posted Jul 21, 2020 - 06:44 PDT
Investigating
The Sauce Labs dashboard at https://app.saucelabs.com is not responding. Automated testing, Sauce Connect tunnels and other services not requiring the UI are unaffected. We are investigating.
Posted Jul 21, 2020 - 05:37 PDT
This incident affected: Web Interface (Sauce UI, Analytics).