A SSL certificate in the chain of the certificate used for TLS 1.2 on https://app.testobject.com has expired.
Any client (web browser, REST API client) using TLS 1.2 and making requests to https://app.testobject.com may see “certificate has expired” errors. Any client using TLS 1.3 is unaffected. We are working to rectify this issue.
2019-October-4 Minor Service Incident
Incident Report for Sauce Labs US West Data Center
Resolved
saucelabs.com is loading normally again. All services are fully operational.
Posted Oct 05, 2019 - 00:26 PDT
Update
saucelabs.com is still not loading fully. We keep investigating.
Posted Oct 04, 2019 - 22:01 PDT
Update
We continue to investigate loading issues with saucelabs.com
Posted Oct 04, 2019 - 20:35 PDT
Investigating
saucelabs.com is not responding. We are investigating.
To login to our application please use https://app.saucelabs.com/login
Posted Oct 04, 2019 - 19:57 PDT
This incident affected: Web Interface (saucelabs.com).