Wait times are intermittently spiking to 100 or more seconds on all clouds. These spikes only last about three minutes and occur about once every two hours. We are investigating the cause.
2019-March-10 Minor Service Incident
Incident Report for Sauce Labs US West Data Center
Postmortem

Dates:

March 10th, 2019 9:12 PM - 10:16 PM PDT

What happened:

Customers could not upload files to our RDC storage system, causing any tests requiring these files to be unusable.

Why it happened:

One of our network carriers performed maintenance which impacted the speed of some communications, including those to our storage vendor.

How we fixed it:

We shifted traffic from the problematic carrier to our redundant, working carrier.

What we are doing to prevent it from happening again:

We are improving our carrier connectivity monitoring so we can detect and undertake corrective measures faster in order to facilitate smooth and timely uploads of customer applications for RDC under any circumstances.

Posted 5 months ago. Mar 18, 2019 - 10:56 PDT

Resolved
This incident has been resolved.
Posted 5 months ago. Mar 10, 2019 - 22:29 PDT
Investigating
Services relying on uploads to our storage are not functioning for Real Devices. This includes capturing test assets and uploading new version of existing apps. We are investigating.
Posted 5 months ago. Mar 10, 2019 - 22:00 PDT
This incident affected: Automated RDC Testing (Automated RDC Testing).