A SSL certificate in the chain of the certificate used for TLS 1.2 on https://app.testobject.com has expired.
Any client (web browser, REST API client) using TLS 1.2 and making requests to https://app.testobject.com may see “certificate has expired” errors. Any client using TLS 1.3 is unaffected. We are working to rectify this issue.
2020-February-27 Service Incident
Incident Report for Sauce Labs US West Data Center
Postmortem

Dates:

Thursday February 27 8:06 AM - 9:00 AM PT

What happened:

The Sauce Labs San Jose datacenter was non-operational for approximately 18 minutes starting at 8:06 am. There was a backlog of jobs for another 22 minutes for both Android and Mac clouds; it took 36 minutes to work through the PC cloud backlog and return to a stable and performant state.

Why it happened:

A communication failure between the Sauce Labs platform and database resulted in our inability to process jobs.

How we fixed it:

Unnecessary connections to the database were closed to assist in its recovery and cloud capacity was diverted to expedite processing of the job backlog.

What we are doing to prevent it from happening again:

We’re adding additional database resilience features to isolate failed nodes without causing disruption to the platform. We also have architectural work in progress that will reduce the time required to recover and work through a job queue.

Posted Mar 06, 2020 - 11:57 PST

Resolved
All our clouds, UI and REST endpoints are working as expected. All services are now fully operational.
Posted Feb 27, 2020 - 09:18 PST
Monitoring
All our clouds, UI and REST endpoints have recovered. We will continue to monitor closely.
Posted Feb 27, 2020 - 09:05 PST
Investigating
app.saucelabs.com, some automated tests and tunnels might be slow to start. We are investigating.
Posted Feb 27, 2020 - 08:31 PST
This incident affected: Sauce Connect (Sauce Connect VM), Manual Testing (Manual VM Testing), Web Interface (Sauce UI, saucelabs.com), Automated VM Testing (Automated PC Testing, Automated Mac Testing, Automated iOS Simulator Testing, Automated Android Emulator Testing), and REST API (REST API VMs).