A SSL certificate in the chain of the certificate used for TLS 1.2 on https://app.testobject.com has expired.
Any client (web browser, REST API client) using TLS 1.2 and making requests to https://app.testobject.com may see “certificate has expired” errors. Any client using TLS 1.3 is unaffected. We are working to rectify this issue.
2019-March-11 Service Incident
Incident Report for Sauce Labs US West Data Center
Postmortem

Dates:

March 11th, 2019 2:53 PM - 4:06 PM PDT

What happened:

Our ondemand and API endpoints were unreachable for our US-based product.

Why it happened:

A subtle error in our configuration automation caused a key proxy service to stop working in our US West environment. This issue had not emerged in our other production environments, despite having deployed the same change using the same automation.

How we fixed it:

We reverted the change.

What we are doing to prevent it from happening again:

We’ve refactored the configuration automation so that this issue is no longer possible.

Posted Mar 18, 2019 - 10:54 PDT

Resolved
We have recovered and all systems should be returned to normal.
Posted Mar 11, 2019 - 16:04 PDT
Monitoring
We have taken remedial action and are monitoring.
Posted Mar 11, 2019 - 15:38 PDT
Update
We are continuing to investigate this issue.
Posted Mar 11, 2019 - 15:01 PDT
Investigating
Our Virtual Desktop, Emulator, and Simulator services are inaccessible right now. We are taking remedial action.
Posted Mar 11, 2019 - 14:58 PDT
This incident affected: Sauce Connect (Sauce Connect VM), Manual Testing (Manual VM Testing), Automated VM Testing (Automated PC Testing, Automated Mac Testing, Automated iOS Simulator Testing, Automated Android Emulator Testing), and REST API (REST API VMs).