A SSL certificate in the chain of the certificate used for TLS 1.2 on https://app.testobject.com has expired.
Any client (web browser, REST API client) using TLS 1.2 and making requests to https://app.testobject.com may see “certificate has expired” errors. Any client using TLS 1.3 is unaffected. We are working to rectify this issue.
2020-March-17 Service Incident
Incident Report for Sauce Labs US West Data Center
Postmortem

Dates:

Tuesday March 17 10:31 AM - 11:06 AM PT

What happened:

Customers using our US-WEST datacenter were unable to load our website, login to our UI, or run tests.

Why it happened:

Our internal service health monitoring mechanisms were set to be too aggressive. This caused user authentication to fail on parts of our system.

How we fixed it:

We have revised our service health monitoring settings to more moderate values.

What we are doing to prevent it from happening again:

We have extended times for our health checks and implemented additional monitoring measures to get notified about potential issues earlier if something similar happens in the future.

Posted Mar 25, 2020 - 11:19 PDT

Resolved
Tunnels and site are working reliably. All services are now fully operational.
Posted Mar 17, 2020 - 12:00 PDT
Update
Our engineers have taken remedial action and we are seeing tunnels and website load more reliably. We will continue to monitor.
Posted Mar 17, 2020 - 11:24 PDT
Investigating
app.saucelabs.com and saucelabs.com are not available or loading slowly. Additionally tunnels might be slow to load or unresponsive. We are investigating.
Posted Mar 17, 2020 - 10:57 PDT
This incident affected: Sauce Connect (Sauce Connect VM), Manual Testing (Manual VM Testing), and Web Interface (Sauce UI, Analytics, saucelabs.com).