Screener.io will be having a planned emergency maintenance window on Monday, August 24th from 8pm to 10pm PDT.
You may see some errors during that time.
2020-August-27 Service Incident
Incident Report for Sauce Labs US West Data Center
Postmortem

Dates:

Thursday, August 27 9:30 AM - 4:30 PM PDT

What Happened?

Due to issues experienced by NTT, one of our third party IP transit providers, traffic from Sauce Labs to resources hosted on AWS was failing. 

Why Did It Happen?

NTT experienced a routing issue on their network.

How Was It Resolved?

We re-routed traffic from NTT and then engaged the NTT NOC. 

Why Are We Doing To Ensure It Never Happens Again?

We are identifying appropriate monitoring tests that can check external dependencies and report carrier routing issues in a more timely manner.

Posted Sep 15, 2020 - 09:19 PDT

Resolved
All our services have recovered successfully. All services are now fully operational
Posted Aug 27, 2020 - 16:59 PDT
Monitoring
After remedial action, traffic is flowing as expected. We will continue to monitor.
Posted Aug 27, 2020 - 16:25 PDT
Investigating
We have gotten multiple reports of slowness or inability to run automated tests or tunnels predominantly over AWS.
We are investigating and taking remedial action.
Posted Aug 27, 2020 - 16:14 PDT
This incident affected: REST API (REST API VMs, REST API RDC), Sauce Connect (Sauce Connect VM, Sauce Connect RDC), Automated VM Testing (Automated PC Testing, Automated Mac Testing, Automated iOS Simulator Testing, Automated Android Emulator Testing), and Automated RDC Testing (Automated RDC Testing).