Screener.io will be having a planned emergency maintenance window on Monday, August 24th from 8pm to 10pm PDT.
You may see some errors during that time.
2020-September-21 Service Incident
Incident Report for Sauce Labs US West Data Center
Postmortem

Dates:

Monday, September 21 02:45 AM - 07:39 AM PDT 

What happened:

A change in the infrastructure of one of our vendors resulted in network link saturation.

Why it happened:

The vendor misconfigured a new router.

How we fixed it:

The Sauce Labs network team executed a network link failover.

What we are doing to prevent it from happening again:

We are adding additional monitoring and alerts around network link saturation and for connectivity between VMs and the rest of our infrastructure

Posted Oct 07, 2020 - 08:49 PDT

Resolved
The issue is resolved and all services are back to fully operational status.
Posted Sep 21, 2020 - 08:04 PDT
Update
We've made some changes to address the high wait times, but we are still seeing a high error rate with Mac and iOS simulator tests. We continue to investigate.
Posted Sep 21, 2020 - 05:59 PDT
Update
Wait times for Mac desktop and iOS simulator tests continue being elevated. Some new tests will timeout before the test starts. We are investigating.
Posted Sep 21, 2020 - 04:26 PDT
Update
We are continuing to investigate this issue.
Posted Sep 21, 2020 - 04:18 PDT
Investigating
Wait times for Mac desktop and iOS simulator tests are elevated. We are investigating.
Posted Sep 21, 2020 - 04:12 PDT
This incident affected: Manual Testing (Manual VM Testing) and Automated VM Testing (Automated Mac Testing, Automated iOS Simulator Testing).