A SSL certificate in the chain of the certificate used for TLS 1.2 on https://app.testobject.com has expired.
Any client (web browser, REST API client) using TLS 1.2 and making requests to https://app.testobject.com may see “certificate has expired” errors. Any client using TLS 1.3 is unaffected. We are working to rectify this issue.
2019-December-10 Service Incident
Incident Report for Sauce Labs US West Data Center
Postmortem

Date:

December 10th, 14:20 - 15:05

What happened:

Some customers experienced high wait times running tests in our PC, Mac, &/or Android clouds in our US-West datacenter.

Why it happened:

A failure within our DNS infrastructure resulted in a loss of connectivity from an availability zone to our control plane for 20 to 40 minutes at a time.

How we fixed it:

We’ve modified the configuration of our DNS servers to respond to the error condition and recover immediately.

What we are doing to prevent it from happening again:

  • We’ve developed extensive playbooks that will allow us to diagnose and respond more rapidly to an event where our VMs have lost connectivity to our control plane.
  • We’ve deployed new test infrastructure that validates our configuration and gives us rapid feedback to the conditions and quality of our environment
  • We’ve deployed additional logging and monitoring of our Load Balancing and DNS infrastructure.
  • We’ve configured additional network level logging to provide advanced diagnostics and replay of failure scenarios.
Posted Jan 09, 2020 - 10:21 PST

Resolved
Wait times have returned to normal on our PC cloud. All services are fully operational.
Posted Dec 10, 2019 - 15:20 PST
Investigating
Wait times on our PC Cloud are high. We are investigating.
Posted Dec 10, 2019 - 14:58 PST
This incident affected: Automated VM Testing (Automated PC Testing).