A SSL certificate in the chain of the certificate used for TLS 1.2 on https://app.testobject.com has expired.
Any client (web browser, REST API client) using TLS 1.2 and making requests to https://app.testobject.com may see “certificate has expired” errors. Any client using TLS 1.3 is unaffected. We are working to rectify this issue.
2020-June-23
Incident Report for Sauce Labs US West Data Center
Resolved
This incident has been resolved.
Posted Jun 23, 2020 - 01:37 PDT
Monitoring
We have taken remedial action and are monitoring services to ensure correct functionality.
Posted Jun 23, 2020 - 00:35 PDT
Investigating
Sauce Connect Tunnels for US Real Device Testing are not starting, We are investigating the cause.
Posted Jun 23, 2020 - 00:04 PDT
This incident affected: Sauce Connect (Sauce Connect RDC).