A SSL certificate in the chain of the certificate used for TLS 1.2 on https://app.testobject.com has expired.
Any client (web browser, REST API client) using TLS 1.2 and making requests to https://app.testobject.com may see “certificate has expired” errors. Any client using TLS 1.3 is unaffected. We are working to rectify this issue.
2019-October-4 Service Incident
Incident Report for Sauce Labs US West Data Center
Postmortem

Dates:

October 4th, 2019 18:47 -19:30 PDT

What happened:

Some customers experienced high wait times running tests in our PC, Mac, & Android clouds in our US West datacenter

Why it happened:

We ran an urgent batch job that overloaded our database. Consequently, current tests were unable to complete and new tests were unable to start.

How we fixed it:

We killed the job, which returned our service to its normal state.

What we are doing to prevent it from happening again:

Future jobs of this scope will be divided into smaller batches that can be run sequentially, using a single thread and an increased database cache size. We also intend to monitor the database and core systems more closely during any similar updates.

Posted Oct 14, 2019 - 09:20 PDT

Resolved
Wait times are back to normal. All services are now fully operational.
Posted Oct 04, 2019 - 19:30 PDT
Monitoring
We have taken remedial action. We are monitoring closely.
Posted Oct 04, 2019 - 19:11 PDT
Investigating
Wait times on our PC, Mac and Android Cloud are high. We are investigating.
Posted Oct 04, 2019 - 18:47 PDT
This incident affected: Manual Testing (Manual VM Testing) and Automated VM Testing (Automated PC Testing, Automated Mac Testing, Automated iOS Simulator Testing, Automated Android Emulator Testing).