A SSL certificate in the chain of the certificate used for TLS 1.2 on https://app.testobject.com has expired.
Any client (web browser, REST API client) using TLS 1.2 and making requests to https://app.testobject.com may see “certificate has expired” errors. Any client using TLS 1.3 is unaffected. We are working to rectify this issue.
2020-June-04 (PST) Service Incident
Incident Report for Sauce Labs US West Data Center
Postmortem

Dates:

Thursday, June 4, 8:00 - 9:30 AM CEST

What happened:

Customers experienced intermittent failures when starting new Real Device Cloud live testing sessions on all platforms in our EU and US datacenters.

Why it happened:

We experienced performance issues in our live testing services which resulted in state changes of sessions becoming out of sync between our backend and frontend systems. This made those sessions appear stuck or take longer than usual.

How we fixed it:

We collected debug data and restarted the affected services which cleared the situation.

What we are doing to prevent it from happening again:

We analyzed the data we collected during the incident and fixed the underlying issues. In addition, we added monitoring to detect issues while starting live testing sessions faster.

Posted Jun 12, 2020 - 02:44 PDT

Resolved
This incident has been resolved.
Posted Jun 04, 2020 - 02:11 PDT
Monitoring
We have taken remedial action and are monitoring services to ensure functionality.
Posted Jun 04, 2020 - 00:32 PDT
Investigating
Live Testing sessions against Real Devices are not starting reliably. Automated testing is unaffected. Our engineers are investigating.
Posted Jun 04, 2020 - 00:16 PDT
This incident affected: Manual Testing (Manual RDC Testing).