Screener.io will be having a planned emergency maintenance window on Monday, August 24th from 8pm to 10pm PDT.
You may see some errors during that time.
2020-Nov-17 RDC Service Incident
Incident Report for Sauce Labs US West Data Center
Resolved
Device availability is back to normal. All services are operational.
Posted Nov 17, 2020 - 12:40 PST
Monitoring
We have identified the issue and took remedial actions. Device availability is back to normal. We are monitoring the situation.
Posted Nov 17, 2020 - 11:22 PST
Identified
We have identified the problem and are currently working on a fix.
Posted Nov 17, 2020 - 10:28 PST
Update
We are continuing to investigate this issue.
Posted Nov 17, 2020 - 09:29 PST
Investigating
Real devices are intermittently not being released for use after test sessions, resulting in reduced numbers of available devices and user concurrency being consumed. We are investigating
Posted Nov 17, 2020 - 09:26 PST
This incident affected: Manual Testing (Manual RDC Testing) and Automated RDC Testing (Automated RDC Testing).