A SSL certificate in the chain of the certificate used for TLS 1.2 on https://app.testobject.com has expired.
Any client (web browser, REST API client) using TLS 1.2 and making requests to https://app.testobject.com may see “certificate has expired” errors. Any client using TLS 1.3 is unaffected. We are working to rectify this issue.
2020-July-01 Minor Service Incident
Incident Report for Sauce Labs US West Data Center
Resolved
This incident has been resolved and full functionality is restored. If you experience issues with our web application please contact support@saucelabs.com.
Posted Jul 01, 2020 - 21:58 PDT
Monitoring
We have identified the root cause as a service provider outage. Service is being restored by the provider and we are seeing a greatly reduced impact on our own services. We are continuing to monitor.
Posted Jul 01, 2020 - 21:49 PDT
Investigating
Interactions with the Sauce Labs web application take a long time to complete. Customers may notice pages becoming unresponsive for a period of time. We are investigating.
Posted Jul 01, 2020 - 21:33 PDT
This incident affected: Web Interface (Sauce UI, Analytics, saucelabs.com).