A SSL certificate in the chain of the certificate used for TLS 1.2 on https://app.testobject.com has expired.
Any client (web browser, REST API client) using TLS 1.2 and making requests to https://app.testobject.com may see “certificate has expired” errors. Any client using TLS 1.3 is unaffected. We are working to rectify this issue.
2019-June-21 Service Incident
Incident Report for Sauce Labs US West Data Center
Resolved
Wait times are back to normal. All services are fully operational.
Posted Jun 21, 2019 - 10:13 PDT
Update
Wait times are recovering. We'll continue to monitor the situation closely.
Posted Jun 21, 2019 - 09:52 PDT
Investigating
We are experiencing high wait times on PC, Android, and Mac Clouds. We are investigating.
Posted Jun 21, 2019 - 09:13 PDT
This incident affected: Manual Testing (Manual VM Testing, Manual RDC Testing) and Automated VM Testing (Automated PC Testing, Automated Mac Testing, Automated iOS Simulator Testing, Automated Android Emulator Testing).