A SSL certificate in the chain of the certificate used for TLS 1.2 on https://app.testobject.com has expired.
Any client (web browser, REST API client) using TLS 1.2 and making requests to https://app.testobject.com may see “certificate has expired” errors. Any client using TLS 1.3 is unaffected. We are working to rectify this issue.
2019-February-27 Service Incident
Incident Report for Sauce Labs US West Data Center
Postmortem

Dates:

February 27th, 2019 20:00 - 20:15 pm PST

What happened:

The Automated Tests tab was returning a 500 error.

Why it happened:

A change was introduced which caused some requests to not include required parameters. These requests were not handled and caused the 500 error.

How we fixed it:

A patch containing the fix was applied.

What we are doing to prevent it from happening again:

We are adding this case to our test suites, ensuring that issues like this are caught early in the pipeline.

Posted Mar 11, 2019 - 07:29 PDT

Resolved
The Automated Test tab has returned to normal. All services are fully operational.
Posted Feb 27, 2019 - 20:31 PST
Investigating
The Automated Tests tab is returning a 500 error. Other services are working and tests should continue to run as normal.
Posted Feb 27, 2019 - 20:01 PST
This incident affected: Web Interface (Sauce UI).