A SSL certificate in the chain of the certificate used for TLS 1.2 on https://app.testobject.com has expired.
Any client (web browser, REST API client) using TLS 1.2 and making requests to https://app.testobject.com may see “certificate has expired” errors. Any client using TLS 1.3 is unaffected. We are working to rectify this issue.
2019-December-20 Service Incident
Incident Report for Sauce Labs US West Data Center
Resolved
We have taken remedial action. Test assets should be uploaded after each test.
Posted Dec 20, 2019 - 15:16 PST
Update
We are continuing to investigate the issue where emulator, simulator, and desktop test assets not uploaded once a test concludes.
Posted Dec 20, 2019 - 13:01 PST
Investigating
Test assets (logs, videos, screenshots) for virtual devices and desktop tests may not upload when a test concludes. We are investigating.
Posted Dec 20, 2019 - 12:20 PST
This incident affected: Manual Testing (Manual VM Testing) and Automated VM Testing (Automated PC Testing, Automated Mac Testing, Automated iOS Simulator Testing, Automated Android Emulator Testing).